Instalando Inkscape 0.91 em Debian Jessie

No repositório padrão do Debian Jessie temos a versão 0.48 do Inkscape e dessa versão para cá muitas funcionalidades e correções foram implementadas. A versão atual é a 0.91 e podemos instalar sem a necessidade de compilar acrescentado o repositório backports.

Acrescente em /etc/apt/sources.list o endereço

deb http://ftp.debian.org/debian jessie-backports main

e rode o comando

apt-get update

e depois

apt-get -t jessie-backports install inkscape

 

Referências

Página oficial do Inkscape

Página do pacote no Debian Jessie Backports

Instruções para repositórios Backports

 

Padrão

Instalando Open Broadcast Software no Debian Jessie

Fiz alguns testes e instalei o OBS em minha máquina. Abaixo as instruções para instalação. Vale lembrar que é necessário ter uma placa de vídeo com GPU.

É necessário ter o repositório non-free habilitado no sources.list

Instalando as dependências

sudo apt-get install libx11-dev libgl1-mesa-dev libpulse-dev libxcomposite-dev \
libxinerama-dev libv4l-dev libudev-dev libfreetype6-dev \
libfontconfig1-dev qtbase5-dev libqt5x11extras5-dev libx264-dev \
libxcb-xinerama0-dev libxcb-shm0-dev libjack-jackd2-dev libcurl4-openssl-dev \
build-essential pkg-config cmake git checkinstall libfdk-aac-dev yasm

 

Compilando FFmpeg

git clone --depth 1 git://source.ffmpeg.org/ffmpeg.git
cd ffmpeg
./configure --enable-shared --prefix=/usr
make -j4
sudo checkinstall --pkgname=FFmpeg --fstrans=no --backup=no --pkgversion="$(date +%Y%m%d)-git" --deldoc=yes
sudo dpkg -i ffmpeg*.deb

 

Compilando OBS

git clone https://github.com/jp9000/obs-studio.git
cd obs-studio
mkdir build && cd build
cmake -DUNIX_STRUCTURE=1 -DCMAKE_INSTALL_PREFIX=/usr ..
make -j4
sudo checkinstall --pkgname=obs-studio --fstrans=no --backup=no --pkgversion="$(date +%Y%m%d)-git" --deldoc=yes
sudo dpkg -i obs-studio_*.deb

Referências

Padrão

AMD Radeon Crimson em Debian Jessie

Tenho uma placa AMD Radeon HD 8690M e nunca usei, pois queria usar na edição de vídeo, mas o Kdenlive não tem suporte a GPU na renderização.

Estou recomeçando meus estudos em streaming e hoje a bola da vez é o Open Broadcaster Software e em suas versões recentes está sendo obrigatório o uso da GPU.

Eu já havia havia instalado o drive próprio da placa quando usava Fedora 20, mas não fiz uso valendo. O desafio agora era deixar rodando legal em Debian Jessie.

Nos repositórios do Debian com non-free tem suporte ao driver fglrx, mas não rodou legal, o cursor do mouse simplesmente não aparece. Resolvi então instalar a versão mais recente e conhecer melhor a solução AMD Radeon Crimson

Depois de baixar o driver e rodar o executável aparece num dialogo a mensagem “Your Graphics adapter is not supported by this driver. Installation will not proceed” e pesquisando vi que é necessário acrescentar radeon.runpm=0 no grub, isso logo na inicialização, pressionando e (para editar) e depois acrescendo na linha que inicia com linux. E aí deu certo.

Para instalação usei como referência um post no fórum do Ubuntu:

sudo apt-get remove --purge xorg-driver-fglrx fglrx*
 sudo apt-get remove --purge fglrx*
 sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
 sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri
 sudo dpkg-reconfigure xserver-xorg
 cd ~/Downloads
 wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86_64' http://www2.ati.com/drivers/linux/radeon-crimson-15.12-15.302-151217a-297685e.zip
 wget --referer=http://support.amd.com radeon-crimson-15.12-15.302-151217a-297685e.zip
 unzip radeon-crimson-15.12-15.302-151217a-297685e.zip
 cd fglrx-15.302
 sudo chmod +x amd-driver-installer-15.302-x86.x86_64.run
 sudo sh amd-driver-installer-15.302-x86.x86_64.run
 sudo amdconfig --initial
 sudo reboot

Num primeiro momento rodou tudo certo, mas depois de abrir o amdcclce e configurar para usar a placa intel as coisas não funcionaram bem e aí num outra pesquisa vi que é necessário reinstalar o pacote libgl1-mesa-glx

sudo apt-get install --reinstall libgl1-mesa-glx:i386

 

Padrão